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Вступление

В данном документе описывается создание особенностей (склонностей), эффект которых  меняется в зависимости от текущей игровой обстановки. Например, мы хотим, чтобы на расстояние открытия диалога с противоположным полом у нас повышался навык красноречия.

Целевая аудитория статьи  – люди уже знакомые с базовыми навыками работы в G.E.C.K. Следовательно, многие простые моменты, такие, как и где создать описание перка здесь не указываются. Основной упор делается на ключевые моменты и их подробное описание. Тем не менее, я старался предоставить материал так, чтобы он был понятен большинству читателей.

Техники, описанные в данной статье, не являются эксклюзивными. Готовые моды, которые используют данные методы, вы можете найти в приложении. Следовательно, я надеюсь, что статья будет интересна людям, которые имеют опыт создания модов, но данной темы не касались вообще или же не могли найти готовые решения и приспособить для своих творческих наработок.
Документ рассчитан на русскую аудиторию, поэтому я буду использовать русские термины (perk – особенность, trait – склонность, skill books – книга навыков, skill magazine – журнал навыков и т.п.). Термины, использующиеся в G.E.C.K дублированы.
Как читать данный документ? Если не понимаете, что зачем и почему – просто повторяйте. После того как все сделаете – посмотрите, что получилось. То, что я предлагаю что-либо попробовать самому, можно опускать пока не разберетесь, что к чему. Потом можно вернуться. Для любителей поэкспериментировать – можете испытать свои силы, ваш КО.
Все примеры, данные в данной статье, проверены мною, но людям свойственно ошибаться, поэтому, если вы нашли ошибку связаться со мной по электронной почте gh0stwizard@mail.ru
Основы
Я пытаюсь освободить твой разум, Нео. 

Но я могу только указать тебе дверь. Ты сам должен войти в нее.

- Морфеус.  Матрица.

Сперва, поговорим об объектах, с которыми взаимодействует главный герой. Со стороны «моддинга» или творческого подхода к изменению игровой механики, все объекты можно поделить на живые и неживые. И это очень важно, т.к. G.E.C.K позволяет оперировать ими совершенно разными путями. Мы остановимся на каждом из них подробно.

Итак, создадим особенность в G.E.C.K и дадим ей конкретное имя. Я буду делать особенность, которая будет менять очки навыка науки на добавочные для навыка оружия в режиме боя с противником. Имя особенности я выбрал Bookman (Ученый), но вы можете назвать так, как пожелаете.
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Рис.1 Окно создания особенности
В части про неживые объекты, мы добавим к особенности еще один эффект, который заставит подсвечиваться полезные книги, такие как журналы для повышения навыков.
Как известно, пункты особенностей (Perk Entries) можно привязать к квесту (Quest), способности (Ability) или точке вхождения, также известной как функция (Entry Point). С последней связкой все ясно, новые функции G.E.C.K. создавать не позволяет, а те, что имеются нам не подходят в контексте нашей задачи. Способности нам тоже не подходят, поскольку ими невозможно управлять, контролировать их поведение и т.п. Но самое главное, эффект способности накладывается из контекста особенности на главного героя. Наш метод исходит с другой точки зрения - эффект накладывается на целевой объект. Это первый ключевой момент.
На данном этапе важно понять, что неважно, с чем или кем взаимодействует главный герой, а также какие параметры и кому мы собрались повышать или отнимать, главному  герою или игровому персонажу (NPC). Важно лишь знать какой именно объект будет играть решающую роль.
Исходя из вышеописанного, нам придется создать квест и привязать его к нашей особенности «Ученый». Создадим новый квест в App Data -> Quest. Назовем его LBookmanQuest.
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Рис. 2 Окно создания квеста

Нам до сих пор неясно как через квест можно управлять наложением эффектов на целевые объекты. Любой квест можно привязать к своему скрипту. Он предоставляет нам широкие возможности по управлению взаимодействия игрока с внешним миром. Не без ограничений конечно.

В двух словах про скрипты. Каждый скрипт в мире G.E.C.K. может быть привязан к трем различным типам (Script Type): квесты (Quest), объекты (Object), эффекты (Effect). Каждый тип накладывает свои ограничения: внешние (какой объект может использовать данный тип скрипта) и внутренние (какие типы блоков (Blocktypes) можно использовать в скрипте).

Мы не станем заострять внимание на этом обширном вопросе. Перейдем к созданию скрипта для нашего новоиспеченного квеста.

Создадим скрипт в Miscellaneous -> Script назовем его LScriptQuestBookman. Обязательно укажите тип Script Type: “Quest”. Код скрипта представлен ниже:

scn LScriptQuestBookman

short bEnabled

Begin GameMode


if (bEnabled == 0)



Set bEnabled to 1


endif


if (bEnabled == 1)



if (Player.IsInCombat == 1)




if (Player.HasMagicEffect LBookmanEffect == 0)





Player.CIOS LBookmanSpell




endif



endif


endif

End

Что делает данный скрипт? Во-первых, мы описываем ситуацию в игровом режиме (блок GameMode), к нему относится всё кроме любых режимов, которые останавливают игровой процесс: меню Pip-Boy, меню игры, диалоги, инвентарь, VATS и т.п. 


Во-вторых, через функцию HasMagicEffect мы можем контролировать сам эффект (как именно описано ниже), также можно указать другие особенности, при которых будет срабатывать эффект, например, когда мы полностью здоровы, а также установить счетчик действия эффекта.


Как видите, я добавил проверку, находится ли главный герой в бою (IsInCombat). Да, вы можете указать собственные проверки, такие как IsSneaking (режим скрытности), проверку пола (GetIsSex), количества крышек (GetGold) и других. Все ограничивается лишь вашей фантазией!


Опишем логику скрипта: если на игроке нет эффекта LBookmanEffect, то мы запускаем заклинание LBookmanSpell на игрока. Функция CIOS (CastImmediateOnSelf) заставляет моментально использовать «заклинание» на игроке. 

Данный скрипт G.E.C.K не сохранит, т.к. в нем присутствуют названия функций, которые еще не определены (LBookmanEffect, LBookmanSpell). Оставьте это окно пока открытым. 

Нам надо написать данные функции, но для начала краткий вводный курс про эффекты в G.E.C.K. Из первой реализации Bethesda нам достались понятия заклинания (Spell) и описания его эффекта. Заклинания описываются в Game Effects -> Actor Effect. Но так как мы играем в пост ядерную игру, где нет места магии и волшебству, просто запомните, что здесь расположены названия эффектов, воздействий на игрока, персонажей или, глобально, объектов. Описания эффектов располагаются в Game Effects -> Base Effect, т.е. то, как именно ведет себя эффект, что добавляет или отнимает, какие визуальные или звуковые эффекты при этом применяются.

Создайте «заклинание» и его описание с именами LBookmanEffect в Game Effects -> Base Effect и LBookmanSpell в Game Effects -> Actor Effect, соответственно. Задайте им соответствующие описания.
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Рис. 3 Окно создания заклинания (воздействия)
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Рис. 4 Окно создания эффекта (описание воздействия)
Теперь после создание данного эффекта и его описания, можно сохранить и закрыть окно скрипта для квеста LScriptQuestBookman. Я знаю, самое вкусное у нас впереди и вам не терпится узнать все поскорей, но нам некуда торопиться, наша главная задача научится создавать свое, а не просто копировать готовое. Поэтому вернемся на самое начало и приведем в порядок то, что уже сделали, чтобы не чего не забыть.


В окне особенности нам необходимо указать пункт для только что созданного нами квеста:
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Рис. 5 Окно особенности с выбранным квестом

Сохраняем и больше не возвращаемся к этому пункту. Перейдем к окну квеста:
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Рис. 6 Заполненное окно квеста
Во-первых, выставим использование нашего скрипта LScriptQuestBookman. Во-вторых, каждый квест запускается с определенным приоритетом (Priority), чем выше значение, тем раньше других он выполнится. Поскольку у нас нетребовательная к ресурсам и не очень важная особенность, выставим это значение в 0.


В-третьих, квест выполняется с определенной задержкой (Script Processing Delay), которая указывается в секундах. По умолчанию, она равна 5 секундам, иными словами наш скрипт будет запускаться раз в 5 секунд. Нас это не устраивает, выставим значение в 0.5 секунды. Сверхнизкие значения задержки (менее 0.1 секунды) могут сказаться на стабильности игры. Остальные параметры вы можете всегда узнать в соответствующем описании.


Основной этап выполнен, именно он задает фундамент понимания того, что именно мы делаем и главное, как.  Закрепим наши полученные знания:

1. Описание особенности начинается с квеста и закрепленного к нему скрипта.

2. В скрипте квеста мы контролируем момент запуска (или снятия) эффекта.
3. Через параметры приоритет и задержка выполнения квеста можно задать частоту исполнения скрипта.
4. Контроль текущего состояния эффекта можно также контролировать в скрипте квеста.
5. Эффект, заклинание, воздействие располагается в Game Effects -> Actor Effect.
6. Техническое описание эффекта описывается в Game Effects -> Base Effect.

Следующий этап лишь опишет детали, то существенное, что мы хотим получить, т.е. результат. Самое вкусное на десерт! Приступим.
Взаимодействие:  живые объекты


Переходим, так сказать, к конкретике. Наш целевой объект это любой живой противник, надеюсь, вы не забыли это.  К живым относятся все NPC или существа, такие как, Когти Смерти и NPC, вроде робота Виктора.
Все эффекты, которые накладываются на живые объекты, описываются в Game Effects -> Actor Effect .  Честно говоря, это условность, не знаю почему, движок игры или G.E.C.K. несовершенны или просто так было задумано, то лучше запомнить, что они относятся только к живым объектам. Но эффекты из Game Effects -> Actor Effect все же накладываются и на неживые объекты с рядом специфичных условий, об этом будет рассказано в другом разделе.
Смело открываем созданный LBookmanSpell. Назначим соответствующий эффект, указав LBookmanEffect. В условиях (Conditions) воспользуемся функцией GetIsObjectType, тем самым мы оградим использование эффекта на другие объекты. Я также добавил функцию IsChild, чтобы оградить наложение эффекта и к персонажам детям (значение Target у всех выставлено Subject).  Это второй ключевой момент.

Вот что у меня получилось в итоге:
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Рис. 7 Окно привязанного эффекта к заклинанию
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Рис. 8 Окно воздействия (заклинания) с привязанным эффектом
Остановимся на первом изображении (Рис. 7). В окне Effect Item мы указали наш эффект LBookmanEffect. 


В поле Range выставим On Touch (при касании), это означает, что эффект будет распространяться на все объекты в округе, до чего можно прикоснуться или увидеть. Вспомним, что мы запускаем заклинание LBookmanSpell на себя (Player.CIOS LBookmanSpell из скрипта LScriptQuestBookman), т.е. наш персонаж находится в центр круга воздействия эффекта заклинания, который можно ограничить.
В поле Area я указал 200, что значит 200 игровых футов. В контексте On Touch (при касании) указывает радиус охвата заклинания.
В поле Duration (длительность) я указал 1 секунду, но поскольку наш квестовый скрипт выполняется раз в 0.5 секунды, это создаст постоянный эффект. 


На втором изображении (Рис. 8) у нас окно Actor Effect. До этого я не останавливался на нем из соображения не запутать вас. Теперь на нем можно остановиться подробно.


Я выбрал Type (тип заклинания) Actor Effect, в русском варианте «Эффект (субъект)». Это означает, что эффект накладывается на субъект, целевой объект, в том числе и главного героя. Тип способность (Ability) нам не подходит. Способность всегда активна (обычно активирована единожды) и не имеет ограничений по времени
. Это третий ключевой момент.

Также я указал, что эффект игнорирует визуальные ограничители, такие, как стены, столы, стулья и т.п., галочка напротив Area Effect Ignores LOS.


Script Effect Always Applies указывает, что эффект будет выполняться всегда. Это полезно для заклинаний направленных на себя. Тут надо понимать, что постоянно зацикленный эффект будет отнимать ресурсы системы (в лучшем случае «тормоза» в игре, в худшем «вылет» из игры) и это надо как-то ограничивать. Это можно сделать двумя путями, через описание самого эффекта в Game Effects -> Base Effect, в простейшем случае это скрипт (галочка активна) или через задержку выполнения нашего скрипта для квеста (галочки нет). Мы пойдем через последний вариант.

Остальные параметры я не стану описывать, т.к. они не входят в рамки этой статьи.

И наконец, заключительная часть, это описание самого эффекта, его технические параметры. Этот пункт может сделать то, что вы поставили целью в своей идее. В нашем случае это «перекачивание» навыков из одной «стихии» в другую.


Откроем окно Base Effect c названием LBookmanEffect, если забыли, где это находится, напоминаю в Game Effects -> Base Effect. На Рис. 9 показано как выглядит это окно:
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Рис. 9 Окно создания эффекта (описание воздействия)

Здесь надо обратить внимание на следующее. Effect Archetype (Архетип эффекта) обычно это скрипт (Script) или модификатор значения (Value Modifier). Assoc. Item, соответственно, может указывать имя скрипта или навыка или иного значения. Мы пока оставим все как есть.


В правой части у нас расположены описания визуальных и звуковых эффектов.

Самое важное в этом окне это флаги (Flags). Они напрямую влияют на выбор соответствующих полей в окне Effect Item для заклинания в Game Effects -> Actor Effect. Такие поля как Range (Self, Target, On touch), Duration, Magnitude и другие.

Поскольку наше заклинание (воздействие) вызывается на игрока, ставим галочку на Self. У нас основной субъект это монстры и NPC выставляем Target. Так как эффект распространяется в виде круга с центром в точке расположения главного героя  – галочка напротив Touch.

Я выставил галочку напротив No Magnitude, чтобы сказать, что мы не меняем значения ни на какие величины. Это необязательно.

О трех важных флагах Hostile, Detrimental, Recover рекомендую почитать самостоятельно и разобраться что к чему.


Теперь нам надо описать сам эффект. Делать это будем, как вы догадались с помощью скрипта. Создадим скрипт LScriptEffectBookman, выставите Script Type как Effect. В процессе создания подобных особенностей, хочется как-то контролировать получается у нас задуманное или нет. Ниже я представлю текст скрипта, который просто поджигает объекты. Это наглядно и сразу дает понять, в каком направлении мы движемся.
scn LScriptEffectBookman

ref rSelf

short doOnce

Begin ScriptEffectStart


Set doOnce to 0


if (GetIsReference Player == 1)



Return


else



if (doOnce == 0)




Set rSelf to GetSelf




rSelf.PMS Flames01




Set doOnce to 1



endif 


endif

End

Begin ScriptEffectFinish


if (GetIsReference Player == 1)



Return


else



if (doOnce == 1)




Set rSelf to GetSelf




rSelf.SMS Flames01




Set doOnce to 0



endif


endif

End

Привяжем данный скрипт к описанию нашего воздействия (заклинания) LBookmanEffect. Т.е. в окне Base Effect выставим Effect Archetype равным Script, а Assoc. Item будет именем нашего скрипта, LScriptEffectBookman.

Возможно, вам не терпится увидеть, что же получилось. Можно сделать перерыв и посмотреть на результат своей работы. Напомню, что эффект срабатывает на персонажах и существах когда главный герой в бою. Эффект должен выглядеть в виде пламени на противнике. Попробуйте!
Ну как, классно? Кто-то из вас может перейти к другому разделу или вовсе перестать читать статью, так как уже имеет опыт написания скриптов, ну,  а самых стойких ждет пример, который будет последним в данном разделе.
Перепишем наш скрипт так, чтобы он выполнял, то, что мы задумали, т.е. перекидывал очки навыка Науки в оружейный навык.  Листинг скрипта будет следующим:

scn LScriptEffectBookman
short sSkillValueGuns

; Original Actor Value of Guns Skill

short sSkillValueScience

; Original Actor Value of Science Skill

short sSkillDelta

Begin ScriptEffectStart


Set sSkillValueGuns to Player.GetAv Guns


Set sSkillValueScience to Player.GetAv Science


; Reduce Science skill to 1


Set sSkillDelta to  (1 - sSkillValueScience)


Player.ModAv Science, sSkillDelta


; Add Science delta to Guns skill


Set sSkillDelta to (sSkillValueScience - 1)


if  ((sSkillDelta + sSkillValueGuns) >= 100)



Set sSkillDelta to (100 - sSkillValueGuns)



endif


Player.ModAv Guns, sSkillDelta

End

Begin ScriptEffectFinish


; Return Science to original value


Set sSkillDelta to  (sSkillValueScience - 1)


Player.ModAv Science, sSkillDelta


; Return Guns to original value


Set sSkillDelta to  (1 - sSkillValueScience)


if (sSkillDelta - sSkillValueGuns) <= -100



Set sSkillDelta to (sSkillValueGuns - 100)


endif


Player.ModAv Guns, sSkillDelta

End


Я старался избегать программных «ухищрений», главное чтобы код был понятен.  Как вы заметили, я избавился от переменной doOnce. Обычно такие проверки делают, чтобы свойства эффекта не накладывались дважды. Но поскольку мы здесь изменяем лишь параметры главного героя, эту проверку можно исключить. Когда и зачем включать данный кусок кода решать вам, зависит все от задержки выполнения основного скрипта, в нашем случае квестового и времени действия эффекта, которое назначается в окне Effect Item. Не станем заострять внимание на этом пункте.

Скрипт делает следующее: 
1. Описание начала эффекта описывается в блоке ScriptEffectStart. Сначала уменьшает навык Науки, затем на туже величину увеличивает навык Оружие. 
2. На этапе окончания действия эффекта возвращает все на изначальные значения. Блок ScriptEffectFinish.
С чем можно поэкспериментировать?
1. Выставить для квеста Script Processing Delay значение в 2, 3 или 5 секунды, чтобы почувствовать разницу. Это поможет понять, зачем нужны и когда не нужны блоки ScriptEffectStart, ScriptEffectFinish.
2. В продолжение идеи, избавьтесь от одного из блоков начала или завершения эффекта в скрипте LScriptEffectBookman. Что происходит теперь?

3. Исключите все блоки начала и завершения эффекта, вместо них воспользуйтесь блоком ScriptEffectUpdate.
 Напишите код для повышения или понижения любого навыка.
4. Попробуйте изменить скрипт так, чтобы он «перекачивал» какой либо навык у противника в навык вашего любимого оружия. Уверен, вам понравится такой эффект.
На этом глава про применение эффектов на живых существах заканчивается, и мы переходим к заключительной главе – эффекты, применяемые на неживых объектах.

Воздействия: неживые объекты


Данную главу можно рассматривать с нескольких точек зрения, так как описываемый ниже метод может применяться ко всем объектам. Также этот метод является частным случаем для создания воздействий только для специфичных объектов.


Каждый объект в движке GameBryo  может содержать свой уникальный скрипт. Через этот скрипт можно управлять как поведением самого объекта, так и другими, не связанных с ним. Именно этим путем мы и пойдем.


Это интересно:  попробуйте изменить скрипт LScriptEffectBookman на тот, который просто поджигает объекты. В окне Effect Item для LBookmanSpell убрать все условия (Conditions), а в скрипте LScriptQuestBookman удалить проверку на режим боя и посмотреть, что произойдет. Все объекты в игре должны гореть, как я считал и как многие из вас. К сожалению, это не так и именно это заставило меня написать этот раздел.

На самом деле объекты будут гореть только если вы находитесь на расстоянии возможности активировать их (  «Е): использовать» ).

Создадим скрипт с именем LScriptSubjectBookman и выставим Script Type в Object. Код впишем следующий:

scn LScriptSubjectBookman

ref rSelf

short doOnce

float timer

Begin GameMode


if (player.HasPerk LBookman == 1)



Set rSelf to GetSelf



if (GetDistance Player < 1000)




if (timer < 15)





if (doOnce == 0)






rSelf.PMS Flames01






Set doOnce to 1





endif





Set timer to timer + GetSecondsPassed




else





rSelf.SMS Flames01





Set timer to 0





Set doOnce to 0




endif



else




rSelf.SMS Flames01



endif


endif

End

Во-первых, мы проверяем, есть ли у нашего персонажа нужная особенность. Во-вторых, я включил таймер, который рекомендуется в официальной вики. Также я применил «остановщик» через doOnce. Поскольку значение для timer является значением с плавающей запятой, а блок GameMode выполняется постоянно, уж не знаю как быстро, но точно зависит от частоты вашего процессора, то визуальный эффект Flames01 будет накладываться постоянно до лимитированного значения 15. Вы сами можете убедиться в этом, убрав проверку на doOnce.
Теперь привяжем данный скрипт к целевым объектам. Журналы вы можете найти в Game Effects -> Ingestible. Да, я сначала не поверил, что они находятся здесь, но поверьте, они здесь. Именно таким образом, великие  выходцы из Interplay решили эту задачу. Креативно, но не более. Вот пример как должно выглядеть окно для журнала «Терапевт сегодня»:
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Рис. 9 Окно объекта журнал «Терапевт сегодня»
Книги находятся в другом месте, Items -> Book. Сделайте нужные привязки самостоятельно. Вы можете удостовериться и открыть окна конкретных персонажей, любого иного объекта везде будет поле Script.

Минусом данного метода, как несложно догадаться, является огромное количество рутинной работы по назначению одного и того же скрипта. 

Важно помнить, что совмещая несколько модов использующих данный метод делать соответствующие изменения в скрипте, иначе какой-то мод станет себя неадекватно вести или вообще не работать.

Теперь осталось проверить, все ли работает? Скрипт LScriptSubjectBookman, который был дан выше, вызывает весьма длительную задержку, поэтому начала действия эффекта огня начнется через 15 секунд. Поменяйте значение на то, что удобно для вас.

Вместо заключения


Есть другие пути решения задач приведенных в данной статье, найдите их самостоятельно.  Или используйте метод, описанный в данной статье, в своих задумках и идеях. Именно чувство покорения еще одной проблемы заставляет нас улыбнуться и почувствовать на мгновение себя счастливым.


Сила скриптов поистине безгранична, в этом вы не раз сможете убедиться. Даже скрипт для квеста может стать отдельной техникой по взаимодействию с объектами. Главное помнить, что не все блоки можно описать для квеста, не все для объекта и не все для эффекта. Каждый блок отвечает за свою игровую ситуацию, зная это, вы стали уже на ступень выше.


В приложении ниже вы найдете готовые примеры, с реальными задачами и готовыми решениями. Все они используют технику, приведенную здесь, в той или иной мере. Этот способ зарекомендовал себя со времен «TES IV Oblivion» и «Fallout 3», а теперь живет в «Fallout New Vegas».

Экспериментируйте, проверяйте нестандартные ситуации, достигайте своей цели. Да и что говорить, вы и сами знаете, что нужно делать. Успехов!

Приложение


Список модов, которые используют  техники из данной статьи, рекомендуется к обязательному изучению, если хотите познать большее, чем описано в данном документе:
1. Особенности Detect Life (NIPDetectLife), Shotgun Charger (NIPShotgunCharger) из New and Improved Perks. Вообще, данный мод прекрасный учебник по созданию модов, особенно скриптов для квестов.

2. Изменение параметров (например, скорости) персонажа через скрипт квеста: SPECIAL Fixes.
3. Bullet Time пример взаимодействия нескольких скриптов.
4. Глаза хищника – используем эффекты в зависимости от типа объекта и его состояния.
5. Особенности Проклятый, Ускоренный метаболизм, Привлекательность из OldSchool - Traits.
� �HYPERLINK "http://geck.bethsoft.com/index.php/MenuMode"��Описание блока MenuMode�


� �HYPERLINK "http://cs.elderscrolls.com/constwiki/index.php/GameMode"��Описание блока GameMode�


� � HYPERLINK "http://geck.bethsoft.com/index.php/Function_Page" ��Список всех функций�


� �HYPERLINK "http://geck.bethsoft.com/index.php/CastImmediateOnSelf"��Описание функции CastImmediateOnSelf�


� �HYPERLINK "http://geck.bethsoft.com/index.php/Quest_Data_Tab"��Описание окна создания квестов�


� �HYPERLINK "http://geck.bethsoft.com/index.php/Effect_Item"��Описание полей в Effect Item�


� �HYPERLINK "http://geck.bethsoft.com/index.php/CastImmediateOnSelf"��Подробнее в заметках функции CIOS�





� � HYPERLINK "http://geck.bethsoft.com/index.php/Base_Effect" ��Описание полей Base Effect�


� � HYPERLINK "http://cs.elderscrolls.com/constwiki/index.php/ScriptEffectUpdate" ��Описание ScriptEffectUpdate�
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